Building Ionic App for iOS [notes]

Error:

Creating ios project...
xcode-select: error: tool 'xcodebuild' requires Xcode, but active developer directory '/Library/Developer/CommandLineTools' is a command line tools instance
Cordova can only run in Xcode version 4.6 or greater.
Error: /Users/martin_adamko/.cordova/lib/npm_cache/cordova-ios/3.7.0/package/bin/create: Command failed with exit code 2
    at ChildProcess.whenDone (/usr/local/lib/node_modules/cordova/node_modules/cordova-lib/src/cordova/superspawn.js:135:23)
    at ChildProcess.emit (events.js:98:17)
    at maybeClose (child_process.js:756:16)
    at Process.ChildProcess._handle.onexit (child_process.js:823:5)

I have Xcode-Beta.app installed. Solution: http://stackoverflow.com/questions/17980759/xcode-select-active-developer-directory-error-on-osx-mavericks

$ sudo xcode-select -switch /Applications/Xcode-Beta.app/Contents/Developer
Creating ios project...
Running command: /Users/martin_adamko/apps/test/hooks/after_prepare/010_add_platform_class.js /Users/martin_adamko/apps/test
add to body class: platform-ios
Running command: /Users/martin_adamko/apps/test/hooks/after_prepare/020_remove_sass_from_platforms.js /Users/martin_adamko/apps/test
Installing "com.ionic.keyboard" for ios
Installing "org.apache.cordova.console" for ios
Installing "org.apache.cordova.device" for ios
Running command: /Users/martin_adamko/apps/test/hooks/after_platform_add/010_install_plugins.js /Users/martin_adamko/apps/test

Q: Should I add class to body?

$ ionic build ios

[...]

** BUILD SUCCEEDED **
$ ionic run ios
Running command: /Users/martin_adamko/apps/test/hooks/after_prepare/010_add_platform_class.js /Users/martin_adamko/apps/test
add to body class: platform-ios
Running command: /Users/martin_adamko/apps/test/hooks/after_prepare/020_remove_sass_from_platforms.js /Users/martin_adamko/apps/test
Running command: /Users/martin_adamko/apps/test/platforms/ios/cordova/run 
Error: ios-deploy was not found. Please download, build and install version 1.2.0 or greater from https://github.com/phonegap/ios-deploy into your path. Or 'npm install -g ios-deploy' using node.js: http://nodejs.org/
ERROR running one or more of the platforms: Error: /Users/martin_adamko/apps/test/platforms/ios/cordova/run: Command failed with exit code 1
You may not have the required environment or OS to run this project
$ npm install -g ios-deploy
[...]
npm ERR! Please try running this command again as root/Administrator.
$ sudo npm install -g ios-deploy

[...]

** BUILD FAILED **


The following build commands failed:
    Check dependencies
(1 failure)
ERROR running one or more of the platforms: Error: /Users/martin_adamko/Sites/hosts/faces/faces/platforms/ios/cordova/run: Command failed with exit code 65
You may not have the required environment or OS to run this project

Window > Devices Shows I’m running unsupported version of iOS:

Screen Shot 2015-02-17 at 20.23.20 Screen Shot 2015-02-17 at 20.22.31

To be continued…

Post about WIP